Mainnet Stacks Core Outage

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted May 19, 2025 - 20:10 EDT

Monitoring

The Stacks blockchain is now progressing, and Hiro services are no longer impacted. We're continuing to monitor the network.
Posted May 19, 2025 - 19:55 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 19, 2025 - 15:58 EDT

Identified

Stacks core developers are investigating a network stall, which is impacting Hiro services. Our team is working closely with them to investigate and mitigate.
Posted May 19, 2025 - 15:58 EDT

Investigating

We're experiencing a major outage in the Hiro Mainnet Stacks Core and are currently looking into the issue.
Posted May 19, 2025 - 15:15 EDT
This incident affected: Services for Mainnet (Stacks Blockchain API).